ACI Learning - Degraded www.practice-labs.com performance – Incident details

Degraded www.practice-labs.com performance

Resolved
Operational
Started 4 months agoLasted about 8 hours

Affected

Practice Labs

Degraded performance from 9:02 AM to 9:16 AM, Operational from 9:16 AM to 5:26 PM

www.practice-labs.com

act.practice-labs.com

Degraded performance from 9:02 AM to 9:16 AM, Operational from 9:16 AM to 5:26 PM

Updates
  • Resolved
    Resolved

    What went wrong
    For a brief duration, the websites www.practice-labs.com and act.practice-labs.com encountered a degraded performance causing slow page loads.

    Who was impacted
    Users attempting to access or navigate the platform during this period may have encountered a slow loading screen.

    Why it went wrong
    An ad-hoc SQL query caused rapid fragmentation on the user tables.

    How did we fix it
    Rebuilt primary key indexes as an immediate fix resulting in full operation in production

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are currently investigating an issue where we are seeing degraded performance when attempting to use www.practice-labs.com and act.practice-labs.com platforms. We are continuing to monitor the performance.